Webpack v5 无法使用 uglifyjs-webpack-plugin

编程开发 2021-05-2468℃ 0 0

最近学习使用webpack打包新开发的Typecho主题的CSS和JS,跟着网上的教程使用uglifyjs-webpack-plugin,发现这个插件并不兼容webpack v5,然后搜了一下webpack文档发现一个新插件`可以替换uglifyjs-webpack-plugin`,这里记录一下处理过程。

npm ERR! Could not resolve dependency:
npm ERR! peer webpack@"^4.0.0" from uglifyjs-webpack-plugin@2.2.0
npm ERR! node_modules/uglifyjs-webpack-plugin
npm ERR!   dev uglifyjs-webpack-plugin@"*" from the root project
npm ERR!

处理过程

先安装插件

npm install terser-webpack-plugin --save-dev

然后修改webpackconfig.js

// 引入插件
const TerserPlugin = require("terser-webpack-plugin");
// 配置参数
module.exports = {
  optimization: {
    minimize: true,
    minimizer: [new TerserPlugin()],
  },
};

配置好后Webpack生成的JS就是压缩版本。

评论 (0)
Top